https://github.com/thinktip/luci-theme-neobird/releases

luci-theme

软件包下载安装
# opkg install luci-theme-neobird_1.99-202201272020_all.ipk

openwrt更改主题后不兼容导致无法进后台解决方法

/usr/lib/lua/luci/template.lua:97: Failed to execute template 'sysauth'.

1.查看当前主题
# opkg info luci-theme*
Package: luci-theme-bootstrap
Version: git-22.084.39047-f1d687e
Depends: libc
Status: install user installed
Architecture: all
Installed-Time: 1650113974

Package: luci-theme-neobird
Version: 1.99-202201272020
Depends: libc
Status: install user installed
Architecture: all
Installed-Time: 1652083355

2.修改当前适应的主题
# vi /etc/config/luci

config core 'main'
option lang 'auto'
option resourcebase '/luci-static/resources'
option ubuspath '/ubus/'
option mediaurlbase '/luci-static/neobird' //修改neobird为bootstrap

config extern 'flash_keep'
option uci '/etc/config/'
option dropbear '/etc/dropbear/'
option openvpn '/etc/openvpn/'
option passwd '/etc/passwd'
option opkg '/etc/opkg.conf'
option firewall '/etc/firewall.user'
option uploads '/lib/uci/upload/'

config internal 'languages'
option zh_cn '............ (Chinese Simplified)'

config internal 'sauth'
option sessionpath '/tmp/luci-sessions'
option sessiontime '3600'

3.修改之后重启就进去默认主题了。

发表评论

后才能评论